Back to overview
Degraded

Network disruptions

Jun 03 at 08:47pm CEST
Affected services
Minecraft Network

Resolved
Jun 03 at 09:29pm CEST

We got the update that our traffic will from now on be routed though a backup system to improve the connection.

Updated
Jun 03 at 09:16pm CEST

The issue reoccurred, waiting for feedback from the DDoS protection provider.

Updated
Jun 03 at 09:08pm CEST

Status update from the DDoS Protection provider: "Attack patched [...] Continuing to monitor".
We are hoping it's resolved by now then and the Server will be fully available once again.

Created
Jun 03 at 08:47pm CEST

Currently, we are experiencing some networking issues from our DDoS Protection provider. We sadly are not able to do anything for the time being and have to wait for a fix from their side.