Back to overview
Degraded

Ongoing DDoS Attacks

Mar 17 at 08:30am CET
Affected services
Minecraft Network

Resolved
Mar 17 at 02:48pm CET

The DDoS Protection has been upgraded and prevent future DDoS attacks.

Created
Mar 17 at 08:30am CET

Currently, we are suffering from ongoing DDoS attacks. We are trying our best to resolve these as fast as we can.